grub-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH v3 0/3] Cryptomount detached headers


From: brutser
Subject: Re: [PATCH v3 0/3] Cryptomount detached headers
Date: Sat, 30 Jul 2022 11:20:44 +0200 (CEST)

Maxim, thanks for the reply!
I built the grub payload with the luks2 module as you can see. In the grub config, but also when i test manually, i load at least:

insmod ahci
insmod lvm
insmod cryptodisk
insmod luks2
insmod part_msdos
insmod ext2


Van: Maxim Fomin <maxim@fomin.one>
Aan: The development of GNU GRUB <grub-devel@gnu.org>
Onderwerp: Re: [PATCH v3 0/3] Cryptomount detached headers
Datum: 30/07/2022 08:51:51 Europe/Paris

------- Original Message -------
On Friday, July 29th, 2022 at 6:56 PM, brutser--- via Grub-devel <grub-devel@gnu.org> wrote:


testing detached header failed:

1. built grub payload with following modules: ahci usb_keyboard part_msdos part_gpt at_keyboard cbfs cryptodisk luks2 lvm gcry_rijndael gcry_sha1 gcry_sha256 gcry_sha512
2. encrypt a partition: cryptsetup luksFormat --type luks2 -q -h sha512 -s 512 --pbkdf pbkdf2 --header /path/to/header --luks2-metadata-size=16k --luks2-keyslots-size=512k /dev/sda1
(where --luks2-metadata-size=16k --luks2-keyslots-size=512k is optional, this is just to minimize header size, but I also tested without).
3. from the grub cmd, i try to decrypt this partition using: cryptomount -H /path/to/header (ahci0,msdos1)

4. I also tried luks1 encryption with detached header.

whatever I try, I always get the same error:
"no cryptodisk module can handle this device"

Is this feature not 100% implemented yet, I saw people already verifying the patches and would expect this to be working, so if yes, this seems like a bug.


This error message sounds like luks (or luks2) module was not loaded. Did you load it before running cryptomount command?

Best regards,
Maxim Fomin‚Äč
_______________________________________________
Grub-devel mailing list
Grub-devel@gnu.org
https://lists.gnu.org/mailman/listinfo/grub-devel

reply via email to

[Prev in Thread] Current Thread [Next in Thread]