[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Thu, 28 Dec 2000 11:27:04 +0100 (MET)
On 23 Dec 2000, Marius Vollmer wrote:
> > However, I still recommend to deprecate scm_remember in its current form
> > because of the much more irritating implications with regard to object
> > protection.
> I think this is a good suggestion. The semantics of scm_remember
> really are hairy and scm_remember_1, etc should be easier to
> understand, *provided* that the user understands that it has to use
> them as the _last_ reference to some object.
> Maybe we could give them more descriptive names like
> void scm_remember_upto_here_1 (SCM obj);
> void scm_remember_upto_here_2 (SCM obj1, SCM obj2);
> void scm_remember_upto_here (SCM obj1, ...);
Since I am not one of the 'names should be short' league, I think that
your names are much better :-)
> The function scm_remember should be deprecated alright.
> Dirk could you make that change? We should also replace all uses of
> scm_remember in Guile itself, of course...
Will do it.