[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Critical section review

From: Mikael Djurfeldt
Subject: Re: Critical section review
Date: Wed, 23 Mar 2005 21:35:06 +0100

On Wed, 23 Mar 2005 20:19:22 +0000, Neil Jerram <address@hidden> wrote:
> So this is now just:
>    SCM_RETURN_NEWSMOB (scm_tc16_memoized, scm_cons (exp, env));
> which is a completely mechanical change except that one SCM_UNPACK(...)
> has become ((scm_t_bits) ...) - is the definition of SCM_NEWSMOB correct
> in using (scm_t_bits) rather than SCM_UNPACK ?

Well,I guess so. I'm no SCM_PACK/SCM_UNPACK expert.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]