[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: API naming bugs

From: Neil Jerram
Subject: Re: API naming bugs
Date: Fri, 30 Dec 2005 19:54:08 +0000
User-agent: Gnus/5.1007 (Gnus v5.10.7) Emacs/21.4 (gnu/linux)

Marius Vollmer <address@hidden> writes:

> Andy Wingo <address@hidden> writes:
>>  - scm_frame_begin, unwind_handler, etc -- should change because there
>> is also a SCM-based scm_frame interface
> Yeah, that's unfortunate.  we have two things that are termed a
> "frame": he things dealt with by scm_frame_begin, etc, and the frames
> of a captured stack.  When designing the scm_frame_begin stuff, I
> didn't think about those "other" frames, and when I finally noticed
> that there is a terminology overlap, ... I refused to think too much
> about it since I wanted to use the nice name for my stuff as
> well... Hmm.  Ideally, I think the captured stack frames should be
> called "stack frames".
> Opinions?

Ideally, yes, but I think there is already a body of code using the
existing frame- names.  (At least, I know I have such code in
guile-debugging, and I think others do too, because of the occasional
discussions about getting debugging information out of a stack.)

How about renaming the internal scm_frame functions instead, since
AFAIK they haven't been released yet?  Perhaps scm_context_..., or
scm_dynwind_..., or scm_dc_...?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]