[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Guile-commits] GNU Guile branch, string-abstraction, updated. feda5

From: Mike Gran
Subject: Re: [Guile-commits] GNU Guile branch, string-abstraction, updated. feda5bd1c08d69628ec9fdb5577d5c894b70b6e8
Date: Mon, 27 Apr 2009 06:53:36 -0700

On Mon, 2009-04-27 at 10:16 +0200, Ludovic Courtès wrote:
> Hello,

> Is `read_token2 ()' temporary?  (I didn't see it mentioned in the log.)
> Otherwise I'd vote for a more descriptive name.

It was meant to be temporary.

> >  static scm_t_uint32
> BTW, I'm wondering whether we should have a separate type for wide
> chars, to make the intent clearer (say, `scm_t_char').


> > -    (pass-if "\\x08 backspace"
> > +    (pass-if "\\x08; backspace"
> >        (let ((port (open-output-string)))
> > -   (display "\x08" port)
> > +   (display "\x08;" port)

> We're introducing subtle incompatibilities here, which we'd rather
> avoid, by default at least.  Could you make that a reader option?

I'm getting there.  I pulled this idea of hex escapes out of the R6RS,
but, as a standard, I think it is a poor design.  Part of the reason for
moving hex escapes into their own function in the last push was to try
to centralize them, so that the reader option was possible.  

> Likewise, I think we should avoid gratuitously changing exception
> messages since, unfortunately, they are sort-of part of the API.

I can roll it back if you like.  I only changed it because of this line
in the Gnu coding standards.

"Please do not use the term 'illegal' to refer to erroneous input to a
computer program.  Please use 'invalid' for this, and reserve the term
'illegal' for activities prohibited by law."

> > --- a/test-suite/tests/regexp.test
> > +++ b/test-suite/tests/regexp.test
> > @@ -22,6 +22,8 @@
> >    #:use-module (test-suite lib)
> >    #:use-module (ice-9 regex))
> >  
> > +(setlocale LC_ALL "en_US.iso88591")
> The user doesn't necessarily have this locale.  Can you instead use
> something similar to `under-french-locale-or-unresolved' in `i18n.test'
> or `find-latin1-locale' in `srfi-14.test', perhaps moving it to the
> `(test-suite lib)' module?

If that line ends up remaining more permanent, I will.  

-Mike Gran

reply via email to

[Prev in Thread] Current Thread [Next in Thread]