[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: 1.9.3 check test fail (powerpc-apple-darwin8)

From: David Fang
Subject: Re: 1.9.3 check test fail (powerpc-apple-darwin8)
Date: Fri, 16 Oct 2009 17:18:43 -0400 (EDT)

I'm seeing the following check failure with guile-1.9.3 on
powerpc-apple-darwin8 (plain ../configure, VPATH build):

Running r4rs.test
Running r5rs_pitfall.test
Running r6rs-ports.test
ERROR: In procedure dynamic-func:
ERROR: dlsym(0x103120, scm_init_r6rs_ports): symbol not found

The ÿÿdlsym ()ÿÿ call comes form module/rnrs/io/ports.scm:
 (load-extension "libguile" "scm_init_r6rs_ports")
The failure could mean that dlopen(3) didnÿÿt pick up the right libguile,
which normally shouldnÿÿt happen because the Libtool wrapper script at
ÿÿlibguile/guileÿÿ sets up the right dynamic linker search path.

Can you try ÿÿ./meta/guile -c '(use-modules (rnrs io ports))'ÿÿ?  If that
fails, can you try to somehow check what the dynamic linker search path
is? (I donÿÿt know how to do it on Mac OS X)

        Sorry for the delay.  I tried the pre-install meta/guile.

        $ (use-modules (rnrs io ports))

This fails with the same dlsym error message, whether I run with -c, or interactively. I checked the 'lsof' to see which libraries it is picking up 'lsof -p PID', and it looks like it's picking up all shared libs in the build directory properly:


% meta/guile
$ (for-each (lambda (x) (display x) (newline)) %load-path )

[/Volume/Mercedes2/sw/src/ is where I'm building]

I've checked that symbol table for 'nm libguile/.libs/libguile.dylib' contains a defined symbol for "scm_init_r6rs_ports":

00061d60 T _scm_init_r6rs_ports

Any other ideas?


David Fang

reply via email to

[Prev in Thread] Current Thread [Next in Thread]