[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

build failure just trying to build guile-1.8.7 natively

From: Robert P. J. Day
Subject: build failure just trying to build guile-1.8.7 natively
Date: Wed, 18 Nov 2009 12:11:51 -0500 (EST)
User-agent: Alpine 2.00 (LFD 1167 2008-08-23)

  as a followup to my earlier plea for help, i downloaded the
guile-1.8.7 tarball and tried to build it on my (effectively) fedora
12 system, and ran into exactly the same error:

cat alist.doc arbiters.doc async.doc backtrace.doc boolean.doc
chars.doc continuations.doc debug.doc deprecation.doc deprecated.doc
discouraged.doc dynl.doc dynwind.doc environments.doc eq.doc error.doc
eval.doc evalext.doc extensions.doc feature.doc fluids.doc fports.doc
futures.doc gc.doc goops.doc gsubr.doc gc-mark.doc gc-segment.doc
gc-malloc.doc gc-card.doc guardians.doc hash.doc hashtab.doc hooks.doc
i18n.doc init.doc ioext.doc keywords.doc lang.doc list.doc load.doc
macros.doc mallocs.doc modules.doc numbers.doc objects.doc objprop.doc
options.doc pairs.doc ports.doc print.doc procprop.doc procs.doc
properties.doc random.doc rdelim.doc read.doc root.doc rw.doc
scmsigs.doc script.doc simpos.doc smob.doc sort.doc srcprop.doc
stackchk.doc stacks.doc stime.doc strings.doc srfi-4.doc srfi-13.doc
srfi-14.doc strorder.doc strports.doc struct.doc symbols.doc
threads.doc throw.doc values.doc variable.doc vectors.doc version.doc
vports.doc weaks.doc ramap.doc unif.doc dynl.doc filesys.doc posix.doc
net_db.doc socket.doc regex-posix.doc |
../scripts/snarf-check-and-output-texi          >
guile-procedures.texi || { rm guile-procedures.texi; false; }
ERROR: unknown doc attribute: (location (string . alist.c) (int . 40)
(hash . hash))
make[3]: *** [guile-procedures.texi] Error 1
make[3]: Leaving directory `/home/rpjday/guile-1.8.7/libguile'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/home/rpjday/guile-1.8.7/libguile'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/rpjday/guile-1.8.7'
make: *** [all] Error 2

  so this is no longer an openembedded issue, it's a straight build
issue.  can anyone help?  i simply ran:

  $ ./configure
  $ make


Robert P. J. Day                               Waterloo, Ontario, CANADA

            Linux Consulting, Training and Kernel Pedantry.

Web page:                                

reply via email to

[Prev in Thread] Current Thread [Next in Thread]