[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Preparing for 2.0.6

From: Nala Ginrut
Subject: Re: Preparing for 2.0.6
Date: Tue, 3 Jul 2012 10:43:34 +0800

I thought it's fixed with my patch:
And Noah said it's done in the tree(I think it's stable-2.0), but I
still get the error message like this:

GNU Guile
Copyright (C) 1995-2012 Free Software Foundation, Inc.

Guile comes with ABSOLUTELY NO WARRANTY; for details type `,show w'.
This program is free software, and you are welcome to redistribute it
under certain conditions; type `,show c' for details.

Enter `,help' for help.
scheme@(guile-user)> ,L ecmascript
Happy hacking with ECMAScript!  To switch back, type `,L scheme'.
ecmascript@(guile-user)> 1+1;
While compiling expression:
ERROR: compilation not yet implemented: (case-lambda ((a116 a115) (let
((t118 (class-of a116)) (t117 (class-of a115))) (if (and (eq? t117
c120) (eq? t118 c124)) (p125 a116 a115) (if (and (eq? t117 c120) (eq?
t118 c122)) (p123 a116 a115) (if (and (eq? t117 c120) (eq? t118 c119))
(p121 a116 a115) (cache-miss g114 (list a116 a115))))))) (args
(cache-miss g114 args)))
ecmascript@(guile-user)> var a=1+1;
ERROR: In procedure #<procedure fe9920 ()>:
ERROR: In procedure module-lookup: Unbound variable: js-init

Entering a new prompt.  Type `,bt' for a backtrace or `,q' to continue.
ecmascript@(guile-user) [1]>

On Tue, Jul 3, 2012 at 3:16 AM, Ludovic Courtès <address@hidden> wrote:
> Hello!
> Nala Ginrut <address@hidden> skribis:
>> Hmm...I still get that error message in stable-2.0 branch for ecmascript.
> Which message?
> Ludo’.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]