[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

guile 2.2 will require libgc 7.2

From: Andy Wingo
Subject: guile 2.2 will require libgc 7.2
Date: Sun, 20 Jan 2013 12:47:11 +0100
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/24.2 (gnu/linux)


After talking with Ludovic in IRC, I updated the dependency on libgc in
"master" to require libgc 7.2, released in its final version on March
2012.  The ifdeffery was making it difficult to make needed changes, as
the older versions were lacking some needed interfaces, and making stubs
was introducing bugs.  Libgc 7.2 also seems to have fewer bugs when run
in a multi-threaded mode.

Debian users will probably want to install libgc by hand.  I am a
terrible person and just install it over my system's copy, as they are
binary-compatible.  Hopefully someone packages it soon, though I dispair
a bit:

Users of other platforms mostly have the newer libgc already.

This does not affect the 2.0.x release series.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]