[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [RFC] [PATCH] Provide the ability to write the frame unwinder in Pyt
Re: [RFC] [PATCH] Provide the ability to write the frame unwinder in Python
Thu, 19 Mar 2015 09:03:59 +0100
Gnus/5.13 (Gnus v5.13) Emacs/24.4 (gnu/linux)
On Wed 18 Mar 2015 17:48, Doug Evans <address@hidden> writes:
> On Wed, Mar 18, 2015 at 1:57 AM, Andy Wingo <address@hidden> wrote:
>> On Tue 17 Mar 2015 23:21, Doug Evans <address@hidden> writes:
>>> On Tue, Mar 17, 2015 at 1:57 AM, Andy Wingo <address@hidden> wrote:
>>>>> As to the class of an object passed to a sniffer, how about calling it
>>>>> FrameData? Note that it's not very important from the user's point of
>>>>> view as sniffer code does not ever reference it by name.
>>>> It's true that from user code it barely matters to Python, but Scheme's
>>>> monomorphic flavor makes these things more apparent:
>>>> (frame-data-read-register frame "r0")
>>>> This doesn't read so well to me -- is it "read-register" on a
>>>> "frame-data", or is it "data-read-register" on a "frame" ? A weak point
>>>> but "ephemeral-frame-read-register" avoids the question.
>>> As food for discussion,
>>> I know some people use foo:bar in Scheme to separate
>>> the object "foo" from the operation on it "bar".
>>> -> frame-data:read-register
>> This convention is not often used in Guile. When it is used, it often
>> denotes field access rather than some more involved procedure call --
>> similar to the lowercase "foo_bar()" versus camel-cased "FooBar()" in
>> Google C++ guidelines.
>>> I like having some separator, but I went with what
>>> I thought was the preferred spelling (all -'s).
>>> It's not too late to change gdb/guile to use foo:bar throughout (IMO),
>>> but the door is closing.
>> FWIW, I prefer "-".
> Even though a different character solves a problem?
> What problem does it introduce?
I find it to be uncommon style in Guile and so it doesn't appeal to me.
Of course, what appeals to me is a function of what is common, and I'm
sure anything can work well as long as it's consistent.
Adding a convention for using colons also makes me wonder when to use
colons or dashes. Perhaps that is my real objection.
Note that actually my original concern was not valid in this case;
"frame-data-read-register" is unlikely to be misread, because people
tend to break the name at the verb, if present. "read-register" on a
> The comparison with _ vs CamelCase is apples and oranges.
At least in V8 there is a similarity; there are two conventions for
writing method names: underscores if it's a simple field access or
camel-case for more complicated things. Same decision criteria as colon
versus dash, as I understand the convention. You don't have the
subject/verb punctuation problem but you do have different ways to write
the verb based on what's going on underneath.
Doug if you want a specific coding style do let me know and I'm happy to
change. Please consider these comments to be just gut reactions /