[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: GNU Guile 3.0.9rc1 available for testing!

From: Jan Nieuwenhuizen
Subject: Re: GNU Guile 3.0.9rc1 available for testing!
Date: Sat, 21 Jan 2023 15:58:13 +0100
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/28.2 (gnu/linux)

Thompson, David writes:


> On Fri, Jan 20, 2023 at 10:58 AM Ludovic Courtès <> wrote:
>> Please report any issues you may find.  I’m particularly interested in
>> portability regressions (NetBSD and other BSDs, macOS, MinGW, as well as
>> architectures other than x86_64).
> I was curious about the MinGW build, so I used a Guix command you
> shared to build it:
> guix build guile-next --with-git-url=guile-next=$HOME/Code/guile
> --with-branch=guile-next=main --target=x86_64-w64-mingw32

I've tried twice, but the build didn't finish -- too long silence
time somewhere?  Last time it got to

    wrote `scripts/generate-autoload.go'
      BOOTSTRAP(stage0) GUILEC scripts/help.go
    wrote `scripts/help.go'
      BOOTSTRAP(stage0) GUILEC scripts/lint.go

where it hangs, the build server showing nothing no guix-build-* in
/tmp, and a rebuild doesn't fetch the built package.  So yeah, dunno.

> I then copied the resulting /gnu/store directory somewhere writable,
> copied over all the DLLs (libgc, libunistring, etc.) it needed from
> /gnu/store into the 'bin' directory, and tried running with wine64 but
> it failed:

Yeah, I've been using something like

WINEPATH=$(guix shell wine64 -- winepath -w                                     
    $(echo $(guix gc -R                                                         
                  $(GUIX_PACKAGE_PATH=guix guix build                           
                                     --target=x86_64-w64-mingw32 guile-mingw))) 
               | sed 's,$,/bin,g' | tr '\n' ';')                                
        guix shell wine64 -- wine                                               
        $(GUIX_PACKAGE_PATH=guix guix build --target=x86_64-w64-mingw32         
        -c '(format #t "Hello  ~a world!\n" %host-type)'

that's on the wip-mingw branch that has a guile-mingw package in a

> $ guix shell wine64 -- wine64 guile.exe
> Mingw-w64 runtime failure:
> 32 bit pseudo relocation at 0000000140001568 out of range, targeting
> 0000000319370E80, yielding the value 00000001D936F914.
> abnormal program termination
> ```

Yeah, you need at least

    76950b428 Support for x86_64-w64-mingw32.

or something similar, or another approach for addressing the
SIZEOF_LONG==4 issue on MinGW.  And compile with --disable-jit, AFAIK
nobody got that to work just yet.

> Thanks for all the hard work on the release!



Jan Nieuwenhuizen <>  | GNU LilyPond
Freelance IT | Avatar®

reply via email to

[Prev in Thread] Current Thread [Next in Thread]