[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Textal interface to Guile

From: Dirk Herrmann
Subject: Re: Textal interface to Guile
Date: Fri, 11 May 2001 17:27:21 +0200 (MEST)

On 10 May 2001, Rob Browning wrote:

> Dirk Herrmann <address@hidden> writes:
> > This indicates that SCM_EOL is actually a bad name - I remember to
> > have been tricked by the same misunderstanding.  A better name would
> > be SCM_EMPTY_LIST.  Maybe we should add this renaming to the guile-2.0
> > wishlist...
> Presuming this is appropriate (and I agree it's clearer).  How about
> we immediately make them equivalent and add SCM_EOL
> deprecation/removal to the items for 1.8.0 (or whichever version is
> appropriate) in RELEASE?

I'd really like to do this, but:  SCM_EOL is, according to the
documentation, part of the gh_ interface (like a couple of other constants
as SCM_BOOL_T).  Remember, a long time ago we promised to keep the gh_
interface stable :-)

So, what should we do?  Is there anybody who does prefer SCM_EOL over
SCM_EMPTY_LIST for other reasons than backwards compatibility?  Should we
rename it?  If yes, when should SCM_EOL (after a phase of deprecation) be
removed (1.8.0, 2.0.0, 42.0.0)?

Best regards,
Dirk Herrmann

reply via email to

[Prev in Thread] Current Thread [Next in Thread]