[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Problems building Guile 1.4

From: Gerrit P. Haase
Subject: Re: Problems building Guile 1.4
Date: Sun, 14 Oct 2001 00:31:42 +0200

Richard Bytheway schrieb am 2001-10-11, 8:20:

>I am trying to build Guile 1.4 under Cygwin for use with Lilypond. I grabbed
>the 1.4.tar.gz file from sunsite, and unpacking gives the following error:
>Is this because I cheated the and-let-star.scm file problem? Or is it a
>Cygwin problem?

Come on, you didn't try hard. I have a website created in lilypond wiki
world, where I explained how I build guile with a shared lib, it is a 
little tricky, because guile-1.4 is old and libtool, autoconf, automake
are new.  I have announced this at the cygwin mailing list and at the
guile mailing list and at the lilypond mailinglist.  

I suggest, you should not try to build a dll, because if you need it for
lilypond it may not work, I tried several timnes to build lily, with a
static guile, with a shared one, but always had troubles (never made it:-((
Genarally there was less trouble with the static version, however 
both of the guile version run for me, shared as well as static:)

You may look at the patch I posted there, there is the issue with
and-let-star.scm included also the net_db.c issue included in the patch.

The second option is the 'official' port of guile from the lily folks
which they offer for download.  It works, and is is sufficient to build
lily with it. (If it builds not for you, then not because of their guile-1.4
port, *BTW, it needs to stripped*).

Look at the archives for some threads about lily, guile, python issues.

Look at the wiki:
Ready to run lilypond binaries:

How I tried to build lily:
***Note the comment of 'jcn' at the end of this site, he suggested
that with my kpathsea setup is that was the 
reason why it doesn't work for me to build it***

And the special about guile-1.4-shared:

Much luck,



reply via email to

[Prev in Thread] Current Thread [Next in Thread]