[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Problems making & installing Guile 1.4

From: Byron Hale
Subject: Re: Problems making & installing Guile 1.4
Date: Sun, 19 Aug 2001 04:18:56 -0700

You're both quite right. It is installed. I can't readily change my path,
there are a lot of other things in "/usr/bin," so I renamed guile 1.3
and made a note to myself, incase there are any dependencies.

Some programs install with the full package name in the same directory.

At any rate, Guile 1.4 is up and running. Thanks!

Best Regards,
Byron Hale

At 11:20 AM 4/16/2002 +0200, you wrote:
On Sat, Aug 18, 2001 at 12:39:52AM -0700, Byron Hale wrote:
> Hi,
> The idea of Guile seems a good one. However,
> I am having practical problems on a Linux 6.2,

Red Hat Linux 6.2, I assume...

> x86 box, making & installing Guile 1.4.

> I previously installed Guile 1.3 and it operates.

The distribution's own?

> However, following the instructions for the
> 1.4 tar.gz, I cannot see any result. Operating
> as root, I ./configure and make. But, when I run
> "guile -v," the result is "1.3." I then tried
> "make install," but the results are not detectably
> different by me.

If all is default, the installation goes to /usr/local,
so your new Guile is now in /usr/local/bin/guile. This
is done so that an update of your distribution doesn't
interfere with the things you install `by hand'.

So in now depends on your PATH environment variable.

In a shell window, type

  echo $PATH

You will get a colon (:) separated list of which directories
the shell searches (and in which order), like so:

  barrique:/home/moep# echo $PATH

If /usr/bin is before /usr/local/bin (which is rather typical
for root), chances are good that this is your problem.

> So, what now? I need 1.4 for some other
> software.

I guess you have already 1.4 well and alive on your box.

-- tomas

Guile-user mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]