[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Found a bug in guile 1.6.0

From: Roland Orre
Subject: Re: Found a bug in guile 1.6.0
Date: 27 Dec 2002 01:02:28 +0100

On Fri, 2002-12-27 at 00:08, Marius Vollmer wrote:
>  The best solution is not to use procedure->macro.  Use define-macro
>  (or defmacro) or define-syntax.

>  You could try
>    (define-macro (push! stack obj)
>      `(set! ,stack (cons ,obj ,stack)))

Thanks, that macro definition works fine. I did, however, as this macro
is used in several places in my code, just convert it to a SCM_SYNTAX
which also solved the problem. The problem occured when I was checking
my old code for our recent conversion to guile 1.6. In most places the
old procedure->macro worked well though.

> (Just curious: where did you learn about procedure->macro?  we don't
> want people to use it.)

It's a remaining in my code from around 1990, long before guile, when I
was a heavily scm (which guile is based upon) user.

It seems as I should try to adapt to the new macros :)
Thanks once again!

        Best regards

reply via email to

[Prev in Thread] Current Thread [Next in Thread]