[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Gmp now working, but number.c:147 isinf declared implicitly.

From: Hugh Sasse
Subject: Re: Gmp now working, but number.c:147 isinf declared implicitly.
Date: Fri, 12 Jan 2007 17:37:33 +0000 (WET)

On Fri, 5 Jan 2007, Hugh Sasse wrote:

> I am now getting :
>  gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I.. -D_REENTRANT -pthreads -g -O2 
> -Wall -Wmissing-prototypes -Werror -MT libguile_la-numbers.lo -MD -MP -MF 
> .deps/libguile_la-numbers.Tpo -c numbers.c  -fPIC -DPIC -o 
> .libs/libguile_la-numbers.o
> cc1: warnings being treated as errors
> numbers.c: In function 'xisinf':
> numbers.c:147: warning: implicit declaration of function 'isinf'
> gmake[3]: *** [libguile_la-numbers.lo] Error 1
> gmake[3]: Leaving directory `/export/home/Scratch/hgs/guile-1.8.1/libguile'
> gmake[2]: *** [all] Error 2
> $ ggrep -C 8 isinf config.log
> | int
> | main ()
> | {
> | return trunc ();
> |   ;
> |   return 0;
> | }
> configure:43674: result: no
> configure:43694: checking for isinf
> configure:43706: gcc -o conftest -g -O2   conftest.c -lgmp -lsocket -lnsl -lm 
> -lltdl  >&5
> configure:43712: $? = 0
> configure:43719: test -z "$ac_c_werror_flag" || test ! -s conftest.err
> configure:43722: $? = 0
> configure:43729: test -s conftest
> configure:43732: $? = 0
> configure:43734: result: yes
> configure:43751: checking for isnan
> $
> So configure knwo what it is, but I can't see how to get at this info 
> to modify number.c.  Maybe I need to do something different?

I have now tried a number of things.  This is on Solaris9. 
I can't get it to pickup the definition from the Sun Workshop includes.
The sun man page for isinf claims that it is available in sunmath.h
which we don't have in /usr/include.
I've tried to modify so that AC_CHECK_HEADER is called
to define HAVE_SUNMATH_H if sunmath.h exists.  Running
autoconf > configure
autoconf (GNU Autoconf) 2.60
results in a corrupt configure file (in so far as it just fails when testing 
Starting afresh and using 
autoreconf -if
similarly corrupts the configure file. Unfortunately I noramlly
never touch autoconf etc so don't know the details of their correct

I'm wondering if it is worth trying to install glibc to get around this,
but I'd rather not add too much to my system

Any ideas how to build this successfully on Solaris 9?

        Thank you,

reply via email to

[Prev in Thread] Current Thread [Next in Thread]