[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[SOLVED] Re: Problems building GNU Greg testing framework

From: romel
Subject: [SOLVED] Re: Problems building GNU Greg testing framework
Date: Mon, 10 Jan 2011 20:24:00 -0500 (EST)
User-agent: SquirrelMail/1.4.13

Thanks Ludovic,

I delete config.guess and config.sub, then regenerate them and voila.

I see Greg it's very old, Does have Guile DBI project a plan to remove
this dependency or to give some maintenance to Greg? Just curious.

As a side note, in order to build Guile DBI on Guile 1.9.14 I had to
remove a hardcoded -lguile library reference from /src/test/

libguile_dbd_test_la_LIBADD = -ldl -lz -lguile

libguile_dbd_test_la_LIBADD = -ldl -lz


Romel Sandoval

> Hi!
> address@hidden writes:
>> I'm trying to build GNU Greg 1.4 in order to build Guile DBI but when I
>> run ./configure something goes wrong.
>> $ ./configure --prefix $HOME/opt/
>> loading cache ./config.cache
>> checking host system type... Invalid configuration
>> `x86_64-unknown-linux-gnu': machine `x86_64-unknown' not recognized
> This means that Greg’s ‘config.guess’ (which originates from
> Autoconf)
> is very, very old, and doesn’t know this architecture, leading to:
>> ltconfig: you must specify a host type if you use `--no-verify'
>> Try `ltconfig --help' for more information.
>> configure: error: libtool configure failed
> AFAIK Greg has been mostly unmaintained for several years.  Still, you
> could try regenerating the configure machinery with a current Autoconf
> and see what happens.
> Thanks,
> Ludo’.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]