[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Package Definition Place

From: Kete
Subject: Re: Package Definition Place
Date: Fri, 03 Jan 2014 20:10:56 -0500
User-agent: KMail/4.12 (Linux/3.5.0-40-generic; KDE/4.12.0; i686; ; )

On Friday, January 03, 2014 04:19:26 PM Ludovic Courtès wrote:
> It is called ‘x11’ (to avoid ambiguity with other licenses originating
> from MIT) in the (guix licenses) module.  So you would write
>    (define-module (gnu packages zsh)
>       ...
>        (license (x11-style "http://url-of/the/license";))
> >     guix build: error: zsh: unknown package
> That will be solved by the above.
> HTH!

Thanks, that did help, but I got the following error:
        checking if tcsetpgrp() actually works... notty
        configure: error: no controlling tty
        Try running configure with --with-tcsetpgrp or --without-tcsetpgrp
I tried the first flag, but it "failed to match any pattern in form". I was 
copying the bash.scm, but I'm not sure if Zsh needs the readline and texinfo 
stuff. Maybe I should just attach my package definition as Nikita requested. 
It's attached.

By the way, the license also says some of the scripts are licensed with the 

Attachment: zsh.scm
Description: Text Data

reply via email to

[Prev in Thread] Current Thread [Next in Thread]