[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Package Definition Place

From: John Darrington
Subject: Re: Package Definition Place
Date: Sat, 4 Jan 2014 08:15:40 +0100
User-agent: Mutt/1.5.21 (2010-09-15)

On Fri, Jan 03, 2014 at 08:10:56PM -0500, Kete wrote:
     On Friday, January 03, 2014 04:19:26 PM Ludovic Courtès wrote:
     > It is called ‘x11’ (to avoid ambiguity with other licenses originating
     > from MIT) in the (guix licenses) module.  So you would write
     >    (define-module (gnu packages zsh)
     >       ...
     >        (license (x11-style "http://url-of/the/license";))
     > >        guix build: error: zsh: unknown package
     > That will be solved by the above.
     > HTH!
     Thanks, that did help, but I got the following error:
        checking if tcsetpgrp() actually works... notty
        configure: error: no controlling tty
        Try running configure with --with-tcsetpgrp or --without-tcsetpgrp
     I tried the first flag, but it "failed to match any pattern in form". I 
     copying the bash.scm, but I'm not sure if Zsh needs the readline and 
     stuff. Maybe I should just attach my package definition as Nikita 
     It's attached.

       (let* ((configure-flags

The example in bash.scm is over complicated.  Look at some of the examples in 
xorg.scm to see how to set configure-flags.

PGP Public key ID: 1024D/2DE827B3 
fingerprint = 8797 A26D 0854 2EAB 0285  A290 8A67 719C 2DE8 27B3
See or any PGP keyserver for public key.

Attachment: signature.asc
Description: Digital signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]