[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

GUIX on fedora 14

From: Omar Tarabai
Subject: GUIX on fedora 14
Date: Tue, 7 Jan 2014 14:57:54 +0100


I have Guix 0.5 installed on a fedora 14, 2.6.32 kernel.

Running the following:
guix package --verbose -i tar

I get the error:
guix package: error: build failed: unable to fork: Operation not permitted

I traced the error to the clone() operation in As mentioned by Ludovic in a previous conversation with Matthias Wachs, it seems to be a problem of a missing capability CAP_SYS_ADMIN.
I tried running the daemon as root only or with --build-users-group=guix-builder but I get the same error. I also tried isolating the clone operation in a test script to verify the problem, fails again (running as root).

I tried removing all the CLONE_* flags as recommended by Ludovic, I get the error:
build error: cannot set loopback interface flags: Permission denied

I assume its because of the missing CLONE_NEWNET

It seems that for some reason on this system, processes started with root privileges does not get the CAP_SYS_ADMIN capability. I know this is more of an environment problem than a Guix problem but I was hoping if you guys have any pointers as what could be the issue.

Thanks a lot,

reply via email to

[Prev in Thread] Current Thread [Next in Thread]