[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

guix 0.7 installation

From: Federico Beffa
Subject: guix 0.7 installation
Date: Sat, 30 Aug 2014 14:43:48 +0200

> I've tried to search for the emacs keyword with:
> guix package -s emacs
> and get a listing of some packages, but also the following error:
> ...

I then tried to install emacs anyway, but the gnu substitute was not responsive:

$ guix package -i emacs
;;; note: source file /usr/local/share/guile/site/2.0/srfi/srfi-37.scm
;;;       newer than compiled /usr/local/share/guile/site/2.0/srfi/srfi-37.go
The following package will be installed:
   emacs-24.3    out    /gnu/store/df5arx0v0f5dzqw2rvr6sr8glmxdbml5-emacs-24.3

substitute-binary: ;;; note: source file
substitute-binary: ;;;       newer than compiled
substitute-binary: guix substitute-binary: warning: while fetching server
is unresponsive
substitute-binary: guix substitute-binary: warning: try
`--no-substitutes' if the problem persists

So, I thought that maybe updating was a good idea:

$ guix pull
;;; note: source file /usr/local/share/guile/site/2.0/srfi/srfi-37.scm
;;;       newer than compiled /usr/local/share/guile/site/2.0/srfi/srfi-37.go
starting download of `guix-file.op6sCK' from
ERROR: In procedure put-bytevector: Wrong type argument in position 2
(expecting bytevector): #f
failed to download "guix-file.op6sCK" from
guix pull: error: failed to download up-to-date source, exiting

By the way, I'm using Debian 7.6 and the installed guile is 2.0.5+1-3.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]