[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Copying whole /gnu/store from USB does not work (SOLVED)

From: Pjotr Prins
Subject: Re: Copying whole /gnu/store from USB does not work (SOLVED)
Date: Sun, 12 Apr 2015 12:28:26 +0200
User-agent: Mutt/1.5.21 (2010-09-15)

> > The reason is that the store is really two things: /gnu/store, and
> > /var/guix/db/db.sqlite.  The latter contains meta-data about the former,
> > notably the list of valid store items.
> Aha. That makes sense. If I also copy the db.sqlite it might just
> work then.

It works rather well and is easy. This means we can just bootstrap
from an existing /gnu tree in thu USB distribution provided the
kernel/arch is compatible.

At build time 'guix package -i guix' complained it did not have enough
builders. The guix-daemon did not honour the -M 8 switch, so I had to
add 30 build users on a 32 core machine. Now it is happy.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]