[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH] Update GCJ.

From: Ricardo Wurmus
Subject: Re: [PATCH] Update GCJ.
Date: Mon, 12 Oct 2015 11:49:26 +0200

Ricardo Wurmus <address@hidden> writes:

> “ecj-bootstrap-4.8” appears to be broken on mips64el and armhf (using it
> to bootstrap GCJ results in a broken GCJ on these platforms), and I’m
> hoping that the situation is different for the 4.9 release.

I just tried to build both icedtea6 and icedtea7 with this, but both
fail with the same error, similar to this one:

Rewriting and unlinking classes ... done. 
Calculating hash values for String objects .. done. 
Calculating fingerprints ... done. 
Removing unshareable information ... done. 
Moving common symbols to metadata section at 0x00007fffcc606ae0 ... done. 
Moving vmSymbols to metadata section at 0x00007fffcc8171b8 ... done. 
Moving the remaining symbols to metadata section at 0x00007fffcc818a48 ... 
Moved 57289 symbols, 2170728 bytes.
Moving pre-ordered read-only objects to shared space at 0x00007fffcae00000 ... 
Moving read-only objects to shared space at 0x00007fffcb468f10 ... done. 
Moving string char arrays to shared space at 0x00007fffcb46bbb0 ... done. 
Moving pre-ordered read-write objects to shared space at 0x00007fffcb800000 ... 
Moving read-write objects to shared space at 0x00007fffcc4260a8 ... done. 
Moving String objects to shared space at 0x00007fffcc4878b0 ... done. 
Read-write space ends at 0x00007fffcc4fec30, 13626416 bytes.
Updating references to shared objects ... done. 

An error has occurred while processing the shared archive file.
Unable to write to shared archive file.
Error occurred during initialization of VM
Unable to use shared archive.
Makefile:2670: recipe for target 'stamps/add-archive-ecj.stamp' failed
make: *** [stamps/add-archive-ecj.stamp] Error 1
phase `build' failed after 1465.3 seconds

Earlier there is a warning about a version mismatch:

WARNING: The file jvmti.h is not the same interface as the VM version.
          this workspace has jvmti.h 1.1.102 and 
          HOTSPOT_IMPORT_PATH contains jvmti.h 1.2.1 
WARNING: Possible HotSpot VM interface conflict. 
         HOTSPOT_IMPORT_PATH is used to import files from the VM build. 
         It is also used to verify that any copied files are consistent between 
         these two components. It has been detected that one or more of the 
         VM interface files inside this workspace may not match the interfaces 
         exported by the VM, or the VM versions could not be found. 
         The list of VM interface files is: 
             jvmti.h jvmticmlr.h. 
         This workspace has copies of these files at: 
           ./../src/share/javavm/export and ./../src/solaris/javavm/export 
         for build purposes, and they should contain the same interfaces 
         as the VM versions imported from: 
         If an interface indeed doesn't match, then the use of this interface 
         at JDK runtime could cause serious errors. 
VM Interface Differences: 
Version mis-match

This is probably related.  Too bad.  I’ll try to figure out what’s going
on here.

~~ Ricardo

reply via email to

[Prev in Thread] Current Thread [Next in Thread]