[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: fixed the gnome forever-suspend problem

From: Albin
Subject: Re: fixed the gnome forever-suspend problem
Date: Thu, 17 Mar 2016 22:44:07 +0100
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Icedove/38.6.0


I'm afraid that my experience was not so good on my libreboot +
MacBook2,1 system.  Previously, I also had the forever-suspend problem
in Gnome 3 while it was working fine in Xfce.  After building from
master a few hours ago, however, I was faced with a black screen and was
forced to do a hard shutdown.

Now, the manual shutdown appears to have corrupted the file system on my
fully encrypted disk because libreboot's GRUB fails to decrypt the
drive.  More precisely I get the following error:

> Failed to decrypt master key.
> error: access denied
> error: disk `crypto0' not found.
> error: you need to load the kernel first.

Fortunately I didn't have any valuable data on the disk.

Regarding the media keys I could make the following observations before
the system became unbootable:

* Brightness controls didn't work in GNOME's control panel logged in as
user.  It did worked when logged in as root however.
* Brightness controls worked in Xfce.
* Resume after suspend had stopped working in Xfce after having worked
before the more recent power-management commits.
* In the same manner sound controls had stopped working in Xfce.
* Audio controls were working in GNOME.

It's amaaaazing how things can break some times :)

Anyway, I hope the above information will be of some use in the future.
 I will now install Parabola on the MacBook2,1 but keep GuixSD on my
desktop computer.

Happy hacking!


Den 2016-03-17 kl. 16:37, skrev Alex Sassmannshausen:
> Hello
> Andy Wingo writes:
>> Hi!
>> [...]
>> Anyway!  Give a try to GNOME, it seems to be an OK environment.
>> NetworkManager doesn't work by default yet -- I think we're missing the
>> service -- so you have to still use the wicd control panel.  I think
>> something's not working with media keys either; some daemon not running
>> yet.  Otherwise though GNOME seems to work OK, just as fine as XFCE
>> anyway.
> This works a charm for me: happily using Gnome with lid controlled
> suspend now :D
> It's amaaaazing :-)
>> Andy
>> ps. Although because the media keys aren't working right now, the
>> brightness keys don't work, you can change the brightness via the GNOME
>> control panel, which means that the pkexec + polkit + logind + pam +
>> sudo waltz seems to be working fine :)
> Actually, for me the media keys and the screen brightness keys are
> working fine, so I can confirm that all seems proper! :-)
> Alex

reply via email to

[Prev in Thread] Current Thread [Next in Thread]