[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

make check-system failure: encrypted-root-os

From: Chris Marusich
Subject: make check-system failure: encrypted-root-os
Date: Wed, 27 Jul 2016 22:10:30 -0700


Every time I try to run "make check-system", the test
"encrypted-root-os" fails.  It fails on commit
b1bf155ffd9b160afdf05aff39d3f0b0f6d11589 (July 18, when I it was
introduced), and it fails on debc6360e111e8efc8a938b2aef28e5b3616ada8
(July 26).  I can't find a test log, but the last output from the
command line was this:

--8<---------------cut here---------------start------------->8---
+ mount LABEL=my-root /mnt
[   17.853136] EXT4-fs (dm-0): mounted filesystem with ordered data mode. Opts: 
+ herd start cow-store /mnt
Service cow-store has been started.
+ mkdir /mnt/etc
+ cp /etc/target-config.scm /mnt/etc/config.scm
+ cat /mnt/etc/config
cat: /mnt/etc/config: No such file or directory
environment variable `PATH' set to 
QEMU runs as PID 6
connected to QEMU's monitor
read QEMU monitor prompt
connected to guest REPL
marionette is ready

;;; (uname #("Linux" "gnu" "4.7.0-gnu" "#1 SMP 1" "x86_64"))
note: keeping build directory `/tmp/guix-build-installation.drv-3'
builder for `/gnu/store/drq919a4vikymgmhv14x2x1wqp4wwab2-installation.drv' 
failed with exit code 1
@ build-failed /gnu/store/drq919a4vikymgmhv14x2x1wqp4wwab2-installation.drv - 1 
builder for `/gnu/store/drq919a4vikymgmhv14x2x1wqp4wwab2-installation.drv' 
failed with exit code 1
cannot build derivation 
`/gnu/store/rrif23d8cbbn1wr26rjjcn01yqcch724-encrypted-root-os.drv': 1 
dependencies couldn't be built
PASS: /gnu/store/avcz2mjh8wl418z9irnzn42ky5yy5mxg-basic
PASS: /gnu/store/6363gfph3lsz73b6lbjc70jza10225zm-mcron
PASS: /gnu/store/3zzcb9jr5mgdyj6jrsbbwxk4x1avr4ic-nss-mdns
PASS: /gnu/store/7a82ixw0a800j3lh72fbx8a2fry7cvmn-installed-os
FAIL: /gnu/store/l24vacjwnwcwr0lrrhwwb94zisz2r0j1-encrypted-root-os
Makefile:4837: recipe for target 'check-system' failed
make: *** [check-system] Error 1
--8<---------------cut here---------------end--------------->8---

It fails when I run any of the following commands:

* make check-system
* make -j check-system
* make check-system TESTS='install encrypted-root-os'

I also tried running the test as root, just in case there was some kind
of permissions problem related to KVM or something.  However, it still

I'm not sure how to troubleshoot further.  Does anyone have any ideas?


Attachment: signature.asc
Description: PGP signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]