[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [PATCH] gnu: Add ldc-1.1.0-beta4

From: Frederick Muriithi
Subject: Re: [PATCH] gnu: Add ldc-1.1.0-beta4
Date: Wed, 4 Jan 2017 18:27:48 +0300

On Wed, Jan 4, 2017 at 5:52 PM, Danny Milosavljevic
<address@hidden> wrote:
> Hi,
> On Wed, 4 Jan 2017 17:01:14 +0300
> Frederick Muriithi <address@hidden> wrote:
>> Added ldc-1.1.0-beta4 since all other beta versions from there seem to
>> reuse the same phobos, druntime and dmd-testsuite.
> Thanks for the patch!
> Hmm, you added gdb to the native-inputs but commented out the gdb invocations 
> later? Why?

I worked through the definition at the beginning adding required
packages, then when builds were successful, but tests were failing, I
went through the tests trying to figure out where the issues were, and
fixing them.
For the gdb invocations, the error message kept pointing to the
Makefile as where the issue was, so I tried to go as close to the
error as I could with my current knowledge.
I think that's only one of a number of invocations, but I might be wrong.

> Also, could you ask upsteam whether they add a version flag (or something) 
> for the http tests? So it can be enabled/disabled without huge patches in the 
> future...

Cool. I will.

> Also, why did you comment out unzip? You can add "unzip" to native-inputs.

Hmmm, it never occurred to me that the issue causing the zip tests to
fail was that unzip was missing. The error messages in the failing
tests did not point to that. I will fix this

> Also, why do you add another "patch-phobos" phase? I think the one in ldc, 
> from which you inherit, does the same, no?

Hmm, my understanding of how the package definitions work might be
incomplete: It seemed to me like after you inherited, from a package,
and then added a definition in any of the variables, the new variables
would NOT add to the values of the older ones but rather, they would
completely overwrite the older one.
I will give it one more whirl.

> I think I had the same problem with tzNames before. I think one of the 
> functions there doesn't interpret its argument as a relative path if it 
> contains a slash anywhere, ruining your /gnu/store prefix or something. 
> Please look into it.


Let me work on those items, and maybe submit a better patch later

Frederick M. Muriithi

reply via email to

[Prev in Thread] Current Thread [Next in Thread]