[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: install experience

From: Ludovic Courtès
Subject: Re: install experience
Date: Mon, 23 Jan 2017 15:17:16 +0100
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/25.1 (gnu/linux)

Hi Thomas!

Thanks for your report on your experience.  It’s very helpful in
understanding what’s wrong and in improving the thing!

Thomas Danckaert <address@hidden> skribis:

>  - I had a false start because on my first attempt, I did not have a
>    BIOS boot partition (there was still an EFI system partition,
>    originally from a past windows installation, I think), so the final
>    step of the installation, installing grub, failed. 宋文武 already
>    submitted a patch to point out this requirement in the docs.

Good.  :-)

I hope we can eventually rely on a manual that deals specifically with

>  - During this first attempt, which would ultimately fail for the
>    above reason, I also got an error running “herd start cow-store
>    /mnt”.  The message was:
>     “ERROR. in procedure mount: mount "./rw-store" on "/gnu/store":
> invalid
>     argument”
>    I decided to reboot and try again, but got the same message.
>    However, when running guix system reconfigure, the store in
>    /mnt/gnu/store did get populated (which is the point of cow-store,
>    as I understand it), so perhaps this error was not fatal...
>    On my second attempt (then with the correct boot partition), I did
>    not get this error anymore.  So I have no further information, I'm
>    afraid.  The only difference that I'm aware of between both
>    attempts, was the partitioning scheme (2nd attempt added the BIOS
>    boot partition, and removed a few unnecessary partitions).

People reported it before but I don’t see how this can happen.  At any
rate, there seems to be a bug lurking here, we’ll have to investigate.

>  - I followed advice I thought I'd once read somewhere (though not in
>    the manual), and first installed a basic system with the bare-bones
>    config from
>     and then switched to a full desktop environment after booting into
>     the newly installed system for the first time (perhaps I
>     could/should have just used a full desktop rightaway?).  I had
>     used the wireless during installation, but didn't include
>     wpa_supplicant (and whatever else might be needed to get similar
>     wifi support as the installation image) in my system
>     configuration, so I couldn't use wireless anymore after booting
>     into my new system :-) Therefore, I had to walk over to my router
>     and connect by cable to continue (at least that was the solution I
>     came up with).

Heh.  :-)

>  - When I tried to login as non-root user for the first time, my home
>    directory was not there, and I was sent back to the login screen. I
>    logged in as root and created/chown'ed the home directory myself.
>    Unfortunately, I have no further information here, either.

Could it be that /home is a separate partition?  There’s a bug waiting
to be fixed in this area: <>.

> Now, the system works fine, though I'll try to tweak it for better
> touchpad support, graphics acceleration (I'm gnome3 is currently
> unusable) and sharper fonts.  Those things worked better when it was
> running Ubuntu, though I suspect some of that was due to non-free
> driver blobs etc.

If you find ways to tweak it, let us know how we can improve the default

Thank you!


reply via email to

[Prev in Thread] Current Thread [Next in Thread]