[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: SGE-Pygame mysteriously downgraded on PyPI

From: Ludovic Courtès
Subject: Re: SGE-Pygame mysteriously downgraded on PyPI
Date: Fri, 13 Oct 2017 14:57:42 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/25.3 (gnu/linux)


Kei Kebreau <address@hidden> skribis:

> address@hidden (Ludovic Courtès) writes:
>> Hi!
>> Kei Kebreau <address@hidden> skribis:
>>> I don't know if anyone else has noticed, but it seems that our
>>> sge-pygame package is failing to build because the package version on
>>> PyPI has downgraded from 1.5.1 to 1.5.
>> How can that downgrade lead to a build failure of our package though?
> Our sge-pygame definition uses the source code from PyPI, not from GNU
> Savannah and its mirrors where the project seems to be hosted. Because version
> 1.5.1 is no longer available from PyPI servers, our package fails to
> build.
> I can change the definition to get the tarball from Savannah and its
> mirrors because we already do that for python-xsge, a similar package by
> the same developer.

Ah, got it.

Well, I suggest you should do whichever looks most sensible to you.  If
the downgrade on PyPI was motivated, but we should probably follow
suite.  Otherwise, we could simply use the 1.5.1 tarball from Savannah.



reply via email to

[Prev in Thread] Current Thread [Next in Thread]