[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Chrooting into GuixSD

From: Thorsten Wilms
Subject: Re: Chrooting into GuixSD
Date: Wed, 13 Jun 2018 12:09:13 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Thunderbird/52.5.0

On 13.06.2018 10:13, Nils Gillmann wrote:
Is this ability to chroot into GuixSD worth mentioning in the manual?
IMHO it is not worth to be mentioned in the manual, as it is the same as
for all Linux systems.
Not really, since you can not*fully*  chroot a GuixSD. Some functions
will not work, like interacting with the daemon or what it was. Last
time I tried this was at least 1.5 years ago.

You can interact with the daemon:

  cd /path/to/guix/root
  sudo mount --bind /dev dev
  sudo mount --bind /proc proc
  sudo mount --bind /sys sys
  sudo unshare -m sudo chroot . /run/current-system/profile/bin/bash
  source /etc/profile

  guix-daemon --build-users-group=guixbuild &

If you then `su` to a plain user, do `source /etc/profile` again.

I think all of `guix pull`. `reconfigure` and `package` search, install and update worked here with that approach. `guix download` failed due to nss certificates, until I added:
  export SSL_CERT_DIR="$HOME/.guix-profile/etc/ssl/certs"
export SSL_CERT_FILE="$HOME/.guix-profile/etc/ssl/certs/ca-certificates.crt"

Thorsten Wilms

thorwil's design for free software:

reply via email to

[Prev in Thread] Current Thread [Next in Thread]