[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Chrooting into GuixSD

From: Ludovic Courtès
Subject: Re: Chrooting into GuixSD
Date: Fri, 15 Jun 2018 17:01:50 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/26.1 (gnu/linux)


Thorsten Wilms <address@hidden> skribis:

> You can interact with the daemon:
>   cd /path/to/guix/root
>   sudo mount --bind /dev dev
>   sudo mount --bind /proc proc
>   sudo mount --bind /sys sys
>   sudo unshare -m sudo chroot . /run/current-system/profile/bin/bash
>   source /etc/profile
>   guix-daemon --build-users-group=guixbuild &
> If you then `su` to a plain user, do `source /etc/profile` again.
> I think all of `guix pull`. `reconfigure` and `package` search,
> install and update worked here with that approach. `guix download`
> failed due to nss certificates, until I added:
>   export SSL_CERT_DIR="$HOME/.guix-profile/etc/ssl/certs"
>   export
> SSL_CERT_FILE="$HOME/.guix-profile/etc/ssl/certs/ca-certificates.crt"

I haven’t tried, but something that would be equivalent to booting into
the system is:

  chroot /path/to/guixsd
  /gnu/store/*-guile-2.0.3/bin/guile /run/current-system/boot

It may interfere badly with the running system (like when it tries to
bring up ttys), but maybe it’s OK?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]