[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Chrooting into GuixSD

From: Thorsten Wilms
Subject: Re: Chrooting into GuixSD
Date: Fri, 15 Jun 2018 20:20:01 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Thunderbird/52.5.0

On 15.06.2018 17:01, Ludovic Courtès wrote:
I haven’t tried, but something that would be equivalent to booting into
the system is:

   chroot /path/to/guixsd
   /gnu/store/*-guile-2.0.3/bin/guile /run/current-system/boot

It may interfere badly with the running system (like when it tries to
bring up ttys), but maybe it’s OK?

Well, I tried:

  cd /path/to/guixsd
  chroot . /run/current-system/profile/bin/bash
  source /etc/profile
  guile /run/current-system/boot

guile: warning: failed to install locale
GC Warning: pthread_getattr_np or pthread_attr_getstack failed for main thread
GC Warning: Couldn't read /proc/stat
;;; note: auto-compilation is enabled, set GUILE_AUTO_COMPILE=0
;;;       or pass the --no-auto-compile argument to disable.
;;; compiling /run/current-system/boot
;;; compiled /home/thorwil/.cache/guile/ccache/2.2-LE-8-3.A/gnu/store/8m935f33cg4qzlr9d44ibqmcrwn5c1r4-boot.go
          12 (apply-smob/1 #<catch-closure 1c799c0>)
In ice-9/boot-9.scm:
    705:2 11 (call-with-prompt _ _ #<procedure default-prompt-handle?>)
In ice-9/eval.scm:
    619:8 10 (_ #(#(#<directory (guile-user) 1d26140>)))
In ice-9/boot-9.scm:
   2312:4  9 (save-module-excursion _)
  3822:12  8 (_)
In /run/current-system/boot:
    1:761  7 (_)
In unknown file:
           6 (primitive-load "/gnu/store/llka25n1x5l1nj82mr7xs8pi1if?")
In ice-9/eval.scm:
    619:8  5 (_ #f)
In ./gnu/build/activation.scm:
   439:33  4 (activate-current-system _)
   435:31  3 (boot-time-system)
In ./gnu/build/linux-boot.scm:
     90:3  2 (linux-command-line)
In ice-9/ports.scm:
   439:11  1 (call-with-input-file "/proc/cmdline" #<procedure get-?> ?)
In unknown file:
           0 (open-file "/proc/cmdline" "r" #:encoding #f # #f)

ERROR: In procedure open-file:
In procedure open-file: No such file or directory: "/proc/cmdline"

I _guess_ if I'd bind proc, I would then find out dev and sys has to be taken care of, too, leading back to what I had already.

Thorsten Wilms

thorwil's design for free software:

reply via email to

[Prev in Thread] Current Thread [Next in Thread]