[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Heads-up: New dependency on Guile-Gcrypt

From: Alex Vong
Subject: Re: Heads-up: New dependency on Guile-Gcrypt
Date: Thu, 06 Sep 2018 07:24:02 +0800
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/26.1 (gnu/linux)

Hello everyone,

I think I figure out why it is failing! Firstly, I am building on debian
testing, so the issue may not appear when building guix within
guix. Secondly, I run 'git clean -fdx && git reset --hard' and install
guile-gcrypt before I build, so dirty build dir and missing deps
shouldn't be cause.

address@hidden (Ludovic Courtès) writes:

> Hi Alex,
> Alex Vong <address@hidden> skribis:
>>   CXXLD    guix-daemon
>> /usr/bin/ld: nix/nix-daemon/guix_daemon-guix-daemon.o: in function `main':
>> /home/alexvong1995/scm/guix/nix/nix-daemon/
>> undefined reference to `gcry_check_version'
>> /usr/bin/ld:
>> /home/alexvong1995/scm/guix/nix/nix-daemon/
>> undefined reference to `gcry_control'
> What does “grep LIBGCRYPT config.log” return?
It returns:

LIBGCRYPT_LIBS='-L -lgcrypt'

I think the problem is in '-L -lgcrypt'. Here '-lgcrypt' is interpreted
as a dir instead of a flag. To check this is indeed the case, I run
'make V=1'. Indeed, the command causing the failure is:

g++ -Wall -std=c++11 -g -O2   -o guix-daemon 
nix/nix-daemon/guix_daemon-guix-daemon.o libstore.a libutil.a libformat.a -lz 
-lsqlite3 -L -lgcrypt -lbz2 

And after the I remove the '-L' flag, it compiles! However, I don't know
what is the root cause of this problem. Is there a bug in / or a bug in autotools itself?

> ‘nix/’ expects $(LIBGCRYPT_LIBS) to contain at least “-lgcrypt”,
> but in your case this variable seems to be empty.
> Ludo’.


Attachment: signature.asc
Description: PGP signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]