[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Heads-up: New dependency on Guile-Gcrypt

From: Pjotr Prins
Subject: Re: Heads-up: New dependency on Guile-Gcrypt
Date: Mon, 10 Sep 2018 11:34:58 +0200
User-agent: NeoMutt/20170113 (1.7.2)

Guix does not expose Guile load paths in etc/profile nor
--search-paths. This makes it a bit trickier to solve

** ERROR: In procedure scm-error: no code for module (gcrypt hash)

Guix is built with Guile and Guile has trouble finding the gcrypt
package. One fix is to install guix in a profile and setting the LOAD
PATHS, e.g.:

: guix package -i guix -p ~/opt/guix

: GUILE_LOAD_PATH=~/opt/guix/share/guile/site/2.2/
: GUILE_LOAD_COMPILED_PATH=~/opt/guix/share/guile/site/2.2/

On Thu, Sep 06, 2018 at 11:08:24PM +0200, Ludovic Courtès wrote:
> Hi Paul,
> Paul Garlick <address@hidden> skribis:
> > I tried a 'guix pull' as root and this time it completes.  However,
> > there were warnings generated:
> Could you paste complete commands and outputs?  That would help
> determine the context of the warning/error messages you mention.
> > Now all the guix commands I have tried generate:
> >
> > ERROR: In procedure scm-error:
> > no code for module (gcrypt hash)
> Since you’re upgrading from a very old checkout, note that you’re also
> switching to the new “guix pull”, which populates
> ~/.config/guix/current.
> To be sure you’re using the just-pulled ‘guix’ command, could you run:
>   export PATH="$HOME/.config/guix/current/bin:$PATH"
>   hash guix
>   guix --version
> ?  What’s the output of this?
> Thanks in advance,
> Ludo’.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]