[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: guix pull: error: symlink: File exists

From: Gábor Boskovits
Subject: Re: guix pull: error: symlink: File exists
Date: Thu, 1 Nov 2018 09:49:17 +0100

Hello Laura,

Laura Lazzati <address@hidden> ezt írta (időpont: 2018.
nov. 1., Cs, 3:09):
>> Now I am trying to get the official way working, that is by sourcing
>> ~/.guix-profile/etc/profile, but it does not seem to work yet.
>> (I could of course just source it manually whenever I start a
>> terminal, but this does not feel comfortable)
>> I will have a look if I can simply get it working using . instead of
>> source, or any other reasonable way.
>> (Guix prepares most of the recommended environment variables there)
> With my almost fresh VM, I tried
> guix pull --substitute-urls="";
> And about two hours ago I had it updated.
> Exported the PATH env on mi cli, added it to .profile.
> Then ran guix pull -l
> And got:
> Migrating profile generations to '/var/guix/profiles/per-user/laura'...
> Generation 1    Oct 31 2018 19:44:03    (current)
> guix c16913d
>     repository URL:
>     branch: origin/master
>     commit: c16913d34df610f5e1560ab8da953e32b3a4e7d7
> Generation 2    Oct 31 2018 21:30:12    (current)
>   guix c16913d
>     repository URL:
>     branch: master
>     commit: c16913d34df610f5e1560ab8da953e32b3a4e7d7
> And then tried guix pull again (always with substitute) The only difference 
> was this output by the end:
> Computing Guix derivation for 'x86_64-linux'... \
> nothing to be done
> I don't know if this was the output you were getting. But it is different 
> from what I was getting before.
> Regards :)
> Laura
This seems to be ok so far :)

I have a question, do you still use VirtualBox for the VM-s?
If it is so, maybe you could have a look at this thread:
they are experiencing the hang in the guile test suite on

Best regards,

reply via email to

[Prev in Thread] Current Thread [Next in Thread]