[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: 01/01: gnu: mit-scheme: Update to 10.1.3.

From: Danny Milosavljevic
Subject: Re: 01/01: gnu: mit-scheme: Update to 10.1.3.
Date: Sun, 16 Dec 2018 21:29:44 +0100

Hi Kei,

On Sat, 15 Dec 2018 13:51:43 -0500
Kei Kebreau <address@hidden> wrote:

> Understood. Thanks to you and Ludovic for cleaning up my small mess.

I think it's only a workaround.

What happened to the MIT scheme C fallback?  I tried to fix it for good but then
the armhf-linux build still didn't work:

With the patch below (which may be wrong), I tried:

$ guix build --system=armhf-linux mit-scheme

and got:

>checking for native-code support... configure: error: unable to determine host 

If there was once a architecture-independent MIT scheme, let's use that one to
bootstrap the newer version, if possible.

You can put the following into your config.scm in order to emulate armhf-linux, 
which would
have caught this problem easily:

                   (service qemu-binfmt-service-type
                       (platforms (lookup-qemu-platforms "arm"))
                       (guix-support? #t)))

diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index c7ab00380..25852d2af 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -70,12 +70,7 @@
   #:use-module (ice-9 match))
 (define (mit-scheme-source-directory system version)
-  (string-append "mit-scheme-"
-                 (if (or (string-prefix? "x86_64" system)
-                         (string-prefix? "i686" system))
-                     ""
-                     "c-")
-                 version))
+  (string-append "mit-scheme-" version))
 (define-public mit-scheme
@@ -173,7 +168,7 @@
                                  (string-append version "-i386"))
-                                 (string-append "c-" version)))
+                                 version))
            (match (%current-system)
@@ -182,7 +177,10 @@
-               "05sjyz90xxfnmi87qv8x0yx0fcallnzl1dciygdafp317pn489is"))))))))
+               "05sjyz90xxfnmi87qv8x0yx0fcallnzl1dciygdafp317pn489is"))
+             (_
+              (base32
+               "18kllckm3iky59wk3nvx41kfn56lpp468savvrk41agjza2hqqhy"))))))))
     ;; Fails to build on MIPS, see <>.
     ;; Also, the portable C version of MIT/GNU Scheme did not work in time for

Attachment: pgpm2NnUVwdPh.pgp
Description: OpenPGP digital signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]