[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Guix video repository: First video script commited

From: Giovanni Biscuolo
Subject: Re: Guix video repository: First video script commited
Date: Thu, 28 Feb 2019 11:47:26 +0100

Hi Laura and Björn,

I'm trying to reproduce the build of "01-installation-from-script" but
I'm having some trouble: please is someone willing to try to build that
video and report here on success/failures?

this is my environment and build process:

1. I'm using the master branch (now on commit 03930dc) from

2. my working directory is <somewhere>/guix-videos

3. in my working dir I enter the environment using the
bash script

4. in guix-videos/01-installation-from-script [env]# I run
"./", at this point the build process enters a (infinite?)
loop with this output:

--8<---------------cut here---------------start------------->8---
tail -n 20 01-installation-from-script/en_US/out/firstCli-0913.txt | \
paps --landscape --columns=80 --font "Monospace 20" | \
convert -density 128 \
                -fill black \
                -background white \
                -flatten \
                -rotate 90 \
                -delete 0--2 - 
convert: profile 'icc': 'RGB ': RGB color space not permitted on grayscale PNG 
`01-installation-from-script/en_US/out/firstCli-0913.png' @ 
--8<---------------cut here---------------end--------------->8---

the number of the resulting "firstCli-XXXX.[txt|png]" files is

I've interrupted the process after a few minutes and now I've a total of
2495 files in guix-videos/01-installation-from-script/en_US/out/ 2198 of
them are txt and 306 png

rmlist tells me "==> In total 2495 files, whereof 1965 are duplicates in
176 groups."

while fdupes tells me "2009 duplicate files (in 177 sets), occupying 2.9

only txt are duplicated, png are not

is this duplication and large number of txt files intended or is a
problem with my build environment?

Laura Lazzati <address@hidden> writes:

> I guess I made a mistake today and maybe I was not inside the
> container when creating the video that worked, since I am trying to
> reproduce everything and I still face issues with the fonts.

I'm still not able to reproduce this issue but have you tried adding the
font package to "NECESSARY" variable in

also: could you please remove "USEFUL" and "NICE_TO_HAVE" from the build
environment since we do not strictly need them at build time?

...nevertheless, I agree they are useful and nice to have in our user
(or project) environment for editing/developing purposes :-)

> I  made some minor changes, will be adding again the files of the
> original installer script video

please commit as soon as you want to share your development, in a
dedicated "wip" or "development" branch if you want

> found this, and added in root
> directory a directory named fonts with the ones I used for the videos.

there is no such directory in my checkout: have you committed and pushed

> Still doesn't work. Also made some minor changes to the scripts, and
> removed the Makefile comment. Laura frustrated mode, will go on
> tomorrow looking how I can install the fonts, inside the environment.

try add them (the fonts) as NECESSARY



Giovanni Biscuolo

Xelera IT Infrastructures

Attachment: signature.asc
Description: PGP signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]