[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: X/GDM fails on linux 5.0.7 AMD Radeon RX 580 after system reconfigur

From: Boris A. Dekshteyn
Subject: Re: X/GDM fails on linux 5.0.7 AMD Radeon RX 580 after system reconfigure
Date: Sat, 11 May 2019 00:12:25 +1200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/26.2 (gnu/linux)

Pierre Neidhardt <address@hidden> writes:

> Hi,
> My last system reconfigure dates back to April 17th and works
> flawlessly.
> Yesterday I ran a new one and X / GDM don't start up properly:
> - I can guess bits and pieces of the GDM interface but the screen is
>   torn asunder by the most epic artifacts (green / purple flashing tiles).
> - In a TTY, I see that GDM is restarting in an infinite loop.
> - dmesg reports some "corruption" at the level of the video card (AMD
>   Radeon RX 580).
> The weird thing is that I'm still using Linux 5.0.7 like I was on April
> 17th and everything worked well.
> I've tried both with linux-libre and a custom kernel.
> Have we changed anything to the boot parameters maybe?
> Side question: how do we know which Guix commit was used for a specific
> system generation?  For now the only way I can think of is
> /var/guix/profiles/system-17-link/profile/bin/guix --version
> Anything more convenient?  From Emacs Guix?

See bug#35575. If you have the same symptoms, the problem is most likely
that mesa does not check its shader cache. Working solution - clear

WBR, Boris Dekshteyn

reply via email to

[Prev in Thread] Current Thread [Next in Thread]