[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Running Guix System on Hetzner Cloud

From: Jonathan Brielmaier
Subject: Running Guix System on Hetzner Cloud
Date: Tue, 4 Jun 2019 13:21:47 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Thunderbird/60.7.0

Hi fellow Guix hackers,

the last weekend I tried to install Guix system on the Hetzner Cloud[0].
First I tried to use Ubuntu, install Guix with the installer script and
then initiate Guix with "guix system init /mnt...". This wasn't
successful as Guix system didn't boot.

So I asked them if they could add the Guix ISO to there ISO image
collection and they did it. At the moment only for my account, not general.

They provide some kind of serial console over the browser. So I just
booted the server with Guix ISO mounted. I went through the graphical
installer, which works very well in this environment :)

During the installation step it fails due to missing "virtio_pci" initrd
modules (see hetzner_cloud_installer_fails.png). In the installer there
was no way to bypass this issue. But rebooting and installing manually
with the configuration below did work :)

I think it would be nice if the installer could handle that as he
already cover the "virtio_scsi" module.

In the end I got a working Guix system for 0,05 € :)

Happy hacking

P.S: Did I already mentioned that the installer is _very_ nice?


;; This is an operating system configuration generated
;; by the graphical installer.

(use-modules (gnu))
(use-service-modules databases desktop mail networking ssh xorg)
(use-package-modules admin vim)

  (locale "en_US.utf8")
  (timezone "Europe/Berlin")
    (keyboard-layout "de" "deadacute"))
      (bootloader grub-bootloader)
      (target "/dev/sda")
      (keyboard-layout keyboard-layout)))
  (initrd-modules '("virtio_scsi" "virtio_pci"))
  (swap-devices (list "/dev/sda1"))
    (cons* (file-system
             (mount-point "/")
               (uuid "713cf8af-e503-45f9-9a10-a0c5a4ce709b"
             (type "ext4"))
  (host-name "guixone")
  (users (cons* (user-account
                  (name "jonathan")
                  (comment "Jonathan Brielmaier")
                  (group "users")
                  (home-directory "/home/jonathan")
                    '("wheel" "netdev" "audio" "video")))
      (list (specification->package "nss-certs") nmap vim)
      (list (service dhcp-client-service-type)
            (service openssh-service-type))

Attachment: hetzner_cloud_installer_fails.png
Description: PNG image

reply via email to

[Prev in Thread] Current Thread [Next in Thread]