[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

help updateing go to 1.13

From: Jack Hill
Subject: help updateing go to 1.13
Date: Fri, 7 Feb 2020 22:59:12 -0500 (EST)
User-agent: Alpine 2.20 (DEB 67 2015-01-07)

Hi Guix,

I thought I would try my hand at updating our go package to 1.13. Looking at the release notes [0] it didn't look to bad. What I have so far can be found in the attached patch.

With the patch, go builds. To spot check that everything still looked okay, I also tried to build syncthing. Doing so, however, failed when it tried to fetch a dependency from the network:

 dial tcp: lookup on [::1]:53: read udp [::1]:35040->[::1]:53: 
read: connection refused
command "go" "run" "build.go" "-no-upgrade" failed with status 1
builder for `/gnu/store/5zs0yrcvr0vwsashsn2i5vx1fgynhmaw-syncthing-1.2.2.drv' 
failed with exit code 1

go-github-com-audriusbutkevicius-go-nat-pmp is listed as an input for syncthing. I don't know why the change in compiler version would have caused this. Thoughts?


[1] On thing that might need addition thinking is that `go get` in 1.13 now uses the Google mirror for fetching modules and cheksums which is different than current behavior. I'm not sure if this poses any privacy concerns for the user, and would like to hear what other's think, but this is not the main problem I'm struggling with today.


Attachment: 0001-WIP-gnu-go-update-to-1.13.patch
Description: Text Data

reply via email to

[Prev in Thread] Current Thread [Next in Thread]