[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

powerpc64[le]-linux port progress

From: dftxbs3e
Subject: powerpc64[le]-linux port progress
Date: Sat, 22 Feb 2020 12:39:56 +0100
User-agent: Mozilla/5.0 (X11; Linux ppc64le; rv:68.0) Gecko/20100101 Thunderbird/68.5.0

So here's my current tree: - master branch
Bootstrap binaries are uploaded over LFS at: - master branch
The current issue is during 'glibc-intermediate' in gnu/packages/commencement.scm
The statically linked gawk binary tries to execute:
execve("/gnu/store/eeeeeeeeeeeeeeeeeeeeeeeeeeeeeeee-bash-static-5.0.7/bin/bash", ["sh", "-c", "test -d nptl"], 0x3fffd261ecc0 /* 57 vars */) = -1
According to Ludovic Courtes, store references with 'eeeeeee' characters in them are removed store references.
So I went and tried to strip the reference to bash and replace it with `sh` so that either gawk or any of its dependency can look up `sh` in PATH at bootstrap time (we do not know any path yet).
In the commit history, you can see I tried to patch glibc and gawk, but that does not solve the problem.
The final gawk binary still contains a reference to bash-static, and I have no idea where it comes from.
Do note that during gawk build process, there's a 'set-shell-filename phase, that I removed in gnu/packages/make-bootstrap.scm and instead replace every occurrence of /bin/sh with `sh`.

I would appreciate help here.

Thank you

Attachment: signature.asc
Description: OpenPGP digital signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]