[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: powerpc64[le]-linux port progress

From: dftxbs3e
Subject: Re: powerpc64[le]-linux port progress
Date: Sun, 23 Feb 2020 02:34:28 +0100
User-agent: Mozilla/5.0 (X11; Linux ppc64le; rv:68.0) Gecko/20100101 Thunderbird/68.5.0

On 2/22/20 1:34 PM, Jan Nieuwenhuizen wrote:
> Have you tried building static gawk standalone and check it for that
> bash?  You could do something like
>    grep -ao '/gnu/store/e*-bash' $(./pre-inst-env guix build -e '(@@ (gnu 
> packages make-bootstrap) %static-binaries)')
> On my x86_64-linux system, I get
>    /gnu/store/eeeeeeeeeeeeeeeeeeeeeeeeeeeeeeee-bash
Yes! I used the strings utility. I get two references to bash-static in
the store with 'eeeee'. Speaking of which, do you know if it's possible
to be spawned into an environment where %static-binaries's gawk package
(and only that one) sources are extracted, patched and configured? So
that I can investigate the inclusion of bash-static comfortably.
> For the new Scheme-only bootstrap, I solved a similar problem for
> %bootstrap-mes by replacing the /gnu/store/eee* store-references with
> actual bootstrap file names; see `%bootstrap-mes-rewired' in
> core-updates 
I hear, however that smells like a hack to me, I'd like to avoid
resorting to such unless absolutely necessary. How come it's not
possible to find where that bash-static reference is being inserted?

Attachment: signature.asc
Description: OpenPGP digital signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]