[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Plan for a release!

From: sirgazil
Subject: Re: Plan for a release!
Date: Thu, 05 Mar 2020 11:45:01 -0500
User-agent: Zoho Mail

Hi Joshua,

 ---- On Thu, 05 Mar 2020 08:42:29 -0500  <address@hidden> wrote ----
 > Well I re-installed guix again just now, so that I could test Xfce and MATE. 
 > (1) Since I knew that
 > gnome worked just fine, I decided not to include the gnome service in my 
 > config. I also decided not
 > to include the enlightenment environment.
 > tl;dr  Xfce worked fine, and MATE failed to launch any applications.
 > The first oddity, was GDM. It worked just smoothly, but the default drop 
 > down shows that by default
 > I am going to boot into Gnome. I don't even have the gnome service in the 
 > config. That's a bit odd.

This is a known issue (see

 > Mate started just fine.  I did get a pop-up message 
 > "Authenticate".
 > Authentication is needed to run mat-power-backlight-helper.  I put in my 
 > password, and the dialog went away.  I did not seem to be able to launch 
 > icecat with the Application menu.  The Icecat logo was in the applications 
 > menu, but a popup said "Could not launch GNU Icecat Web Browser".  The error 
 > message is "Failed to execute child process "gio-launch-deskop" (No such 
 > file or directory).  I also could not launch mate terminal for the same 
 > reason.  Actually very few applications could launch.  I could get the file 
 > browser (thunar?) to open, but not much else.  Since MATE did not seem to 
 > work so well, I logged out.

I got a different pop-up message on my first MATE session, but I haven't had 
the time to report it (see
 The message did not appear again after logging out and back in.

I'm not sure, but the problem of launching applications from application menus  
may be related to the issue of launching applications when double-clicking 
files in file managers (Thunar, Caja, etc.) when there is more than one Desktop 
Environment or Window Manager available. Could you please check and see if you get the same behavior? 
If so, it would be helpful if you could report your experience in that bug 
report as well.

 > Joshua
 > 1. I wish I knew how I could have reconfigured my laptop instead of 
 > reinstalling everything. I
 > tried this.
 > chroot /mnt;
 > guix system reconfigure /mnt/etc/config.scm;

I may be missing something from previous messages to the list, but to 
reconfigure the Guix System you can copy the system configuration file in 
"/etc/config.scm" save it wherever you want, modify it to your liking (e.g. 
adding or removing more packages or services), and then

$ guix pull
$ sudo guix system reconfigure /path/to/your/config.scm

reply via email to

[Prev in Thread] Current Thread [Next in Thread]