[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: 1.1.0rc2 available for testing!

From: Ludovic Courtès
Subject: Re: 1.1.0rc2 available for testing!
Date: Mon, 13 Apr 2020 15:45:58 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/26.3 (gnu/linux)


"Robert Smith" <address@hidden> skribis:

> I ran into the same issue that Jesse encountered in December, the
> installer hangs when it tries to connect to wifi, and I can't escape by
> pressing Alt-F2/F3/F12.

When you’re on tty1 (the installer), you have to hit Ctrl-Alt-F12
etc. (note “Ctrl”).  Is it what you tried?

> In the end I just have to hold down the power button. I've tested this
> with different wifi networks and it's always the same. I tried using
> the console to connect to wifi, and everything worked smoothly. The
> only difference from the manual was that I had to use `rfkill unblock
> wifi` before I could bring the interface up. I didn't have this issue
> when I first installed guix, so I downloaded the 1.0.1 installer and
> as I thought the issue wasn't there, and the wifi connection went
> smoothly.

OK.  It could have something to do with the issue about Connman not
starting that Florian reported.

What does /var/log/messages show?  (In particular, messages from
shepherd, connmand, and dbus.)

> I'm not sure how I can get any diagnostic information from my system, if
> you have ideas I'd be happy to try them out. I tested this on my Librem
> 15 v4; I remember from Guix Days that a few other people have Librem
> laptops, I'm curious if they can use the installer to connect to a wifi
> network.

Anyone else with a Librem laptop can give it a try?  You don’t need to
run the full installation, it’s enough to go past the network setup
phase, which is early on.

Thanks for your report,

reply via email to

[Prev in Thread] Current Thread [Next in Thread]