[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Signing emails with mu4e (was Re: Hello, new committer here!)

From: Pierre Langlois
Subject: Re: Signing emails with mu4e (was Re: Hello, new committer here!)
Date: Tue, 01 Sep 2020 13:29:52 +0100
User-agent: mu4e 1.4.13; emacs 27.1

Hash: SHA512

Pierre Langlois writes:

> Pierre Langlois writes:
>> Hello Guix,
>> So, as indicated in our contributing process on the manual, I'm happy to
>> announce maintainers have agreed to give me commit access, thank you
>> everybody!
>> I believe I need somebody to add my GPG keys to the Guix keyring before
>> I can push my first commit. Which I think is going to be
>> (although, if this one is urgent,
>> don't hesitate to push it for me!).
>> If I'm not mistaken, since I'm using a subkey as a signing key, it
>> should be this way (that's what I've had to do sign a personal channel):
>>     (;; primary: "41CA 12EA DE0C F33F 6885  A58F 5719 6E37 E00B 77FD"
>>      "72D5 3D81 8CB6 F4A1 7258  374C A8FC 9E44 7F4F 7D54"
>>      (name "planglois")
> Huh, it looks like the email signature got messed up. I'm using mu4e but
> it wasn't finding my key as it used to. I rolled-back to emacs 26 and
> that seemed to have worked, except the email sent wasn't signed
> properly.
> So, with this email, if I do `M-x mml-secure-message-sign-pgpmime' and
> try and send, I get a backtrace:
> ```
> Debugger entered--Lisp error: (error "Couldn’t find any signer names; try 
> setting `mml-s...")
>   signal(error ("Couldn’t find any signer names; try setting `mml-s..."))
>   error("Couldn't find any signer names%s" "; try setting 
> `mml-secure-smime-sign-with-sender'.")
>   mml-secure-epg-sign(OpenPGP t)
>   mml2015-epg-sign((part (sign . "pgpmime") (tag-location . 477) (contents . 
> "Pierre Langlois writes:\n\n> Hello Guix,\n>\n> So, as ...")))
>   mml2015-sign((part (sign . "pgpmime") (tag-location . 477) (contents . 
> "Pierre Langlois writes:\n\n> Hello Guix,\n>\n> So, as ...")))
>   mml-pgpmime-sign-buffer((part (sign . "pgpmime") (tag-location . 477) 
> (contents . "Pierre Langlois writes:\n\n> Hello Guix,\n>\n> So, as ...")))
>   mml-generate-mime-1((part (sign . "pgpmime") (tag-location . 477) (contents 
> . "Pierre Langlois writes:\n\n> Hello Guix,\n>\n> So, as ...")))
>   mml-generate-mime(nil nil)
>   message-encode-message-body()
>   message-send-mail(nil)
>   message-send-via-mail(nil)
>   message-send(nil)
>   message-send-and-exit(nil)
> ```
> I've tried setting `mml-secure-smime-sign-with-sender' to `t' that's not
> helping.  I'm not sure what's going on, are there any mu4e users here
> that can sign emails? I wonder if it's do to with the recent gnupg
> update instead of emacs.

Right, it works with these variables set:

    (setq mml-secure-openpgp-signers '("KEYID"))
    (setq mml-secure-opengpg-sign-with-sender t)

And using '<#secure method=gpg mode=sign>'

I'm not sure what's broken, this used to "just work" by default without
having to tell emacs where to find the signer key. mmm


reply via email to

[Prev in Thread] Current Thread [Next in Thread]