[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: RISCV porting effort

From: Efraim Flashner
Subject: Re: RISCV porting effort
Date: Fri, 11 Jun 2021 14:16:13 +0300

On Mon, Jun 07, 2021 at 10:09:44AM +0300, Efraim Flashner wrote:
> Upstream u-boot support was merged days ago³ so we should be able to add
> support to our u-boot package soon-ish™.

I added u-boot-sifive-unmatched, although Vagrant pointed out that I may
be missing opensbi as an input. I haven't had a chance to test it yet.

> Where I'm at right now:
> Downloading using the daemon (builtin:download) fails currently, it says
> it doesn't have permissions to open-file to write downloaded files to
> the store.
> I haven't built anything using the bootstrap binaries to see if they
> actually work yet.

I've had some time to play with these parts. I tried the qemu-binfmt
emulation on my Guix System machine and I was able to start building out
the packages while emulating riscv64-linux, so that's a good sign.

As for writing to the store goes, I believe it's a permissions issue
somewhere. With some help on IRC I modified the downloading code and
wrote out some files using the builtin:download function to a file in my
home directory. I also used a minimal reproducer to write a file to the

scheme@(guile-user)> (use-modules (guix gexp)(guix store)(guix monad-repl))
scheme@(guile-user)> ,enter-store-monad
store-monad@(guile-user) [1]> (text-file "foo" "Hello!\n")
$2 = "/gnu/store/r4bq7f7aikj0dlzjcl2cjgal5wvdhvk1-foo"

(ins)efraim@unmatched:~$ cat /gnu/store/r4bq7f7aikj0dlzjcl2cjgal5wvdhvk1-foo

So that works. Could it be that I messed up creating the guixbuild
users? I copy/pasted from the manual, command history shows me I ran:
root@unmatched:/home/efraim# for i in $(seq -w 1 10);   do     useradd -g 
guixbuild -G guixbuild                       -d /var/empty -s $(which nologin)  
             -c "Guix build user $i" --system                guixbuilder$i;   

Efraim Flashner   <>   אפרים פלשנר
GPG key = A28B F40C 3E55 1372 662D  14F7 41AA E7DC CA3D 8351
Confidentiality cannot be guaranteed on emails sent or received unencrypted

Attachment: signature.asc
Description: PGP signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]