[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: core-updates-frozen on powerpc64le-linux

From: Thiago Jung Bauermann
Subject: Re: core-updates-frozen on powerpc64le-linux
Date: Wed, 04 Aug 2021 20:04:42 -0300

Hi Ludo’!

Em quarta-feira, 4 de agosto de 2021, às 17:48:59 -03, Ludovic Courtès 
> Thiago Jung Bauermann <> skribis:
> > Em quarta-feira, 28 de julho de 2021, às 08:50:16 -03, Mathieu Othacehe
> > escreveu:
> [...]
> >> Cuirass has started evaluating this branch here:
> >> According to the
> >> related dashboard, there's still a bit of work required to stabilize
> >> this branch:
> > 
> > There are no results for powerpc64le-linux. Does anyone know why?
> It was turned off in the config at
> <>.  I’ve
> added it now (though maybe it won’t actually build until someone has
> pushed.)

Thanks for the explanation. And thanks for re-adding it!

> Note that currently ci.guix only does emulated powerpc64le-linux because
> the only POWER9 machine we currently have access to (lent by OSUOSL) is
> not running ‘cuirass-remote-worker’.

Ah, I didn’t realise that. I started out my investigations of powerpc64le-
linux CI failures using emulation on my laptop (both with qemu-user and 
qemu-system), and found it to be a bit unreliable. I saw some failures in 
packages’ testsuite results which don’t happen on real hardware. There was 
one in the glib package in particular which happened on the master branch 
and prevented a `guix pull` command from succeeding. This is what prompted 
me to request the Minicloud VM instance.

> It’s a foreign distro (Debian) so
> setting up these things can be a bit tedious.  If you or anyone would
> like to help with this, we can discuss it!

I’d be glad to help set that up and maintain the OSUOSL machine!

> (bordeaux.guix does have a POWER9 build machine behind, but it’s not
> building ‘core-updates-frozen’ currently.)

Nice! I’d be glad to help with that machine as well if there’s anything to 
do on that front.

> > The last Cuirass evaluation of core-updates with powerpc64le-linux
> > results is so I tried to run the
> > failed builds on my VM to see what the current state is. My
> > core-updates-frozen branch was at commit f8458a228224
> > (”build-system/python: Handle missing metadata on Python 2.”) when I
> > did these builds.
> > 
> > At first, I didn’t try the “*tarball*” builds because I didn’t want to
> > focus on the bootstrap binaries. Apart from those, I was glad to see
> > that all failed powerpc64le-linux builds from that evaluation built
> > fine on my VM, except for the ones below:
> > 
> > • gcc-toolchain@4.8
> > • gcc-toolchain@5.5
> > • gmp@4.3.2 aka `(@@ (gnu packages commencement) gmp-boot)`
> > • mpfr@2.4.2 aka `(@@ (gnu packages commencement) mpfr-boot)`
> > • mpc@1.0.3 aka `(@@ (gnu packages commencement) mpc-boot)`
> > 
> > I later tried building ‘bootstrap-tarballs’, but it failed during the
> > build of the static gawk binary.
> > 
> > I also did a `guix pull --branch=core-updates-frozen`, which built a
> > ton of stuff and completed successfully. At the time,
> > core-updates-frozen was at commit 5e4cdb5b3b1d (”gnu: python-django:
> > Fix test failure.”)
> Woow, that’s fairly intense testing!


I was glad to see that powerpc64le-linux was in better shape than I had 

> Does the Coreutils test failure at <>
> happen on real hardware?

Thanks for point it out. I just tested and it doesn’t! I’ll close that 

> > So next step for me is to look into the build failures above. I’ll
> > semi-randomly start with ‘gmp-boot’ and see what I can find out.
> Neat, thank you!

You’re welcome. Patches on issues 49880, 49881 and 49882. :-)


reply via email to

[Prev in Thread] Current Thread [Next in Thread]