[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: python-libcst upgrade and python-flake8

From: Lars-Dominik Braun
Subject: Re: python-libcst upgrade and python-flake8
Date: Fri, 10 Jun 2022 08:27:49 +0200

Hi jgart,

> validating 'flake8' 
> /gnu/store/zaw5z708sldm6v3qxjczcia7gl65dw5x-python-flake8-3.9.2/lib/python3.9/site-packages
> ...checking requirements: ERROR: flake8==3.9.2 
> ContextualVersionConflict(pyflakes 2.4.0 
> (/gnu/store/mxkp1zl64cd3i247shp7njkxad8v13x9-python-pyflakes-2.4.0/lib/python3.9/site-packages),
>  Requirement.parse('pyflakes<2.4.0,>=2.3.0'), {'flake8'})
I believe this was fixed in Guix proper already by upgrading to 4.0.1
and loosening the version checks. In any case it’s not a problem with
the library you are trying to package.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]