[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[bug#34406] [PATCH] gnu: flatpak: Add missing dependencies

From: Emiel Wiedijk
Subject: [bug#34406] [PATCH] gnu: flatpak: Add missing dependencies
Date: Sat, 9 Feb 2019 18:12:43 +0100

* Add gnupg to propagated inputs: flatpak uses gpgme to verify
  repositories, this requires a gpg binary in $PATH, otherwise I get
  this error:
    "GPGME error: Invalid crypto engine"
* Add gsettings-desktop-schemas to propagated inputs: flatpak also
  depends on gsettings-desktop-schemas. Apparantly it is available by
  default on my GNOME desktop, so it works if I run it unprivileged.
  However, in a root prompt, it emits this error message:
    "(flatpak remote-add:19956): GLib-GIO-ERROR **: 09:05:00.003:
     Settings schema 'org.gnome.system.proxy' is not installed"
  The same error occurs, with the package in inputs. For me, flatpak as
  root only works with gsettings-desktop-schemas in propagated-inputs.
 gnu/packages/package-management.scm | 3 +++
 1 file changed, 3 insertions(+)

diff --git a/gnu/packages/package-management.scm 
index c3b195a64..0ab5ce652 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -50,6 +50,7 @@
   #:use-module (gnu packages gnupg)
   #:use-module (gnu packages gnuzilla)
   #:use-module (gnu packages graphviz)
+  #:use-module (gnu packages gnupg)
   #:use-module (gnu packages gtk)
   #:use-module (gnu packages guile)
   #:use-module (gnu packages guile-xyz)
@@ -980,6 +981,8 @@ the bootloader configuration.")
                          (string-append "--with-system-bubblewrap="
                                         (assoc-ref %build-inputs "bubblewrap")
+   (propagated-inputs `(("gnupg" ,gnupg)
+                        ("gsettings-desktop-schemas" 
    (native-inputs `(("bison" ,bison)
                     ("gettext" ,gnu-gettext)
                     ("glib:bin" ,glib "bin") ; for glib-mkenums + gdbus-codegen

reply via email to

[Prev in Thread] Current Thread [Next in Thread]