[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[bug#46278] [PATCH v2] Add fwupd

From: phodina
Subject: [bug#46278] [PATCH v2] Add fwupd
Date: Sun, 14 Aug 2022 21:44:07 +0000


here's updated patch for fwupd.

I attempted to add also Gnome GUI but for some reason the pkgconfig in meson is not detecting the fwupd even though that when ran manually it finds it.

Here's the error:

Found pkg-config: /gnu/store/2b3blhwbag1ial0dhxw7wh4zjxl0cqpk-pkg-config-0.29.2/bin/pkg-config (0.29.2)
Run-time dependency gtk4 found: YES 4.6.6
Run-time dependency gio-2.0 found: YES 2.70.2
Did not find CMake 'cmake'
Found CMake: NO
Run-time dependency fwupd found: NO (tried pkgconfig and cmake)
Looking for a fallback subproject for the dependency fwupd

../source/ ERROR: Git program not found, cannot download fwupd.wrap via git.

A full log can be found at /tmp/guix-build-gnome-firmware-42.2.drv-0/build/meson-logs/meson-log.txt
error: in phase 'configure': uncaught exception:

And here's the search result (I sourced the environment first):

/tmp/guix-build-gnome-firmware-42.2.drv-0/source$ pkg-config --list-all | grep fwupd
fwupdplugin           fwupdplugin - library for plugins to use to interact with fwupd daemon
fwupd                 fwupd - fwupd is a system daemon for installing device firmware

FIY Same error happens when I attempt to build the libaccounts-qt for KDE updates.[1][2]


Attachment: v2-0002-gnu-Add-gnome-firmware.patch
Description: Text Data

Attachment: v2-0001-gnu-Add-fwupd.patch
Description: Text Data

reply via email to

[Prev in Thread] Current Thread [Next in Thread]