[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Health] pgadmin4

From: Edgar_
Subject: Re: [Health] pgadmin4
Date: Wed, 4 Aug 2021 22:07:37 +0200
User-agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:78.0) Gecko/20100101 Thunderbird/78.12.0

Hi Tajwali

I have a similar problem at the moment.

On my Oracle VirtualBox with openSUSE 15.2 and GNU Health 3.6 I could access the GNUHealth server at localhost with the client and I could also access the tables with psql in the console. But I could not access the database with PgAdmin4. So I removed my VirtualMachine and tried to make a fresh installation, but until now I always fail. I installed it also with yast, but probably not in the same way that is described in the docs (because with yast it is easier, I thought). Although the server is running now (use "systemctl start gnuhealth", and then "systemctl status gnuhealth"), I cannot access it through the client (and also not with PgAdmin, of course).

But in the meantime I installed PgAdmin at my Raspberry Pi4 with GNUHealth 3.8, so I can confirm that it works in principle. (I described it also in German at

With a SQL query like

SELECT AS gl_id, gl.test AS gl_test, AS gl_name, AS gltt_name,
gl.patient AS gl_patient, AS gp_name, AS pp_name, pp.lastname AS pp_lastname, gl.date_analysis
FROM public.gnuhealth_lab gl
INNER JOIN public.gnuhealth_lab_test_type gltt ON gl.test =
INNER JOIN public.gnuhealth_patient gp ON gl.patient =
INNER JOIN public.party_party pp ON =
WHERE date_analysis >='2016-01-01 00:00:00' AND date_analysis <='2022-01-01 00:00:00'

you can then e.g. display labtests for a defined period.

Maybe you could describe your problem more in detail and share some screenshots at

then probably somebody (probably not me) will know the solution.

All the best


PS did you solve your problem with the logo?

Am 03.08.2021 um 19:04 schrieb Tajwali Khan:

I have gnuhealth installed thru yast on opensuse 15.2.

The postgres database server was installed thru gnuhealth installation.

Im trying to use pgadmin4 to manage the database. The gnuhealth is not a production system. 

The pgadmin does not connect to the localhost. Does not give anyerror when i give server details 

Any idea what may be causing the connection problem?

On Wed, Jul 28, 2021, 4:19 PM Edgar_H <> wrote:

Dear Tajwali

Probably you have to change the permission rights for the file. You could also login as root and edit the file.

You can add the logo just like in any LibreOfficeWriter document. Maybe you have to play a little around for putting it into the place you like (e.g. header) if you are not familiar with LibreOffice.

All the best


Am 27.07.2021 um 21:36 schrieb Tajwali Khan:
Thanks alot it worked like a charm

One more question pls. How can i edit the report files

Example . I want to add a logo to the file appointment_receipt.fodt How do i do that? 

First of all if i open the file in libreoffice writer i dont hav access to it. The file is readnonly. How can i get full access? 

Secondly shud i add the logo just as i wud to any document. Copy paste logo. Or do i hav to use code for the logo file location.

Kindly if something can guide me. 

On Tue, Jul 27, 2021, 8:20 PM Axel Braun <> wrote:
Am Dienstag, 27. Juli 2021, 15:15:29 CEST schrieb Tajwali Khan:
> I installed the system on opensuse 15.2 from Yast package installer.
> Gnuhealth version 3.6.9
> Database version ghdemo38

That will not work, as the database does not match the server version.

What you can do: add the GNU Health 3.8 repository:

zypper ar -f -p70
ERP:/GNUHealth:/3.8/openSUSE_Leap_15.2/ gh38

Then upgrade:
zypper dup --allow-vendor-change --from gh38

then run trytond-admin -c /etc/tryton/trytond.con -v --all -d $DB_NAME


reply via email to

[Prev in Thread] Current Thread [Next in Thread]